Skip to main content

Black fly s usb3 won’t stay connected to computer

Comments

5 comments

  • Official comment
    TDY_Ifeanyi
    Community team
    Great answers
    Expert (Gold)

    Hello Chris,

    I am not sure if resetting controller would help to resolve this because 5m cable seems too long for laptop connection. One (1) meter cable is recommended for laptop or on-board controller.

    Yes! Purchasing a separate host controller instead of inbuilt one to test this further is a good step to resolve this. Another option to try is with powered usb3 hub or powering camera via GPIO port.

    Please let me know if any of the troubleshooting options helps to get camera stable.

    Regards,

    Ifeanyi

  • TDY_Ifeanyi
    Community team
    Great answers
    Expert (Gold)

    Hello Chris,

    This seems like communication issue between camera and system.

    Please I have some questions to help narrow this down further:

    • Is camera directly plug to system or via usb hub? 
    • What is the length of this usb3 cable?
    • Have you tried to test this camera on a different PC?
    • Does it help swapping camera with another USB cable that is working fine?
    • Are other cameras working fine the same model and also connected to the same PC?
    • Asumming this may be related to power problem, you could try powering camera externally via GPIO port?

    It would also nice to know the current spinnaker sdk version installed in this pc.

    Regards,

    Ifeanyi

    0
  • Chris Mcdonald

    The camera was plugged directly into computer
    5m cable bought from teledyne
    Camera works on my laptop, but camera worked on pc for first 4 days. Thinking my usb controller built in might have went bad but how. Camera gives me 3 green blinks like it is connected fine to usb3. 2 blinks when i plug into usb2. I ordered a pci usb3 controller. Should come today. I hope this works.
    Thank you, if you have an idea to reset my usb3 ports please let me know.

    0
  • TDY_Demos
    Community team
    Expert (Gold)

    Hello Chris,

    Just following up to check if the new host controller resolved your issues or if you still have communication issues between the BFS and your laptop.

    Thank you,

    Demos

    0
  • Chris Mcdonald

    Sorry yes, tech support helped me. I actually had one red port which i didn’t know that meant a gen 3.2. Works great now. Thank you

    0

Please sign in to leave a comment.

Powered by Zendesk